Battlevoid: Harbinger BUG REPORTING


Android 5.0.2
-Admiral, loving the game! Started using defense laser cannons and noticed they aren't causing damage to any targets. Tried engaging multiple types..fighters, drones, missles, carriers. Upgrading damage doesn't resolve issue. I notice no damage on hulls or shields. The big laser cannon works great! Although it could use a little extra range wink wink Wink


I'll have to scratch my previous post, but after closer inspection the defense laser are doing damage. They actually stop projectiles quite often but missles no, not even when upgraded. They 're said to be good against fighters but my observations lean towards bolters or gatlings being better in almost every way. I had assumed that lasers would deal damage in multiple tics per burst. But it seems they function 1 damaging hit(5,10,15 hull) per burst of laser? Where bolters for ex fire numerous shots with each one dealing damage. I think this is why I thought lasers were broken. My appologies.


Hi there!

Yes it might be something with how the damage is registered and how it is shown visually. But yeah they should be doing damage Smile


I am playing with the Achilles ship, and I put a turret on the nose of the ship. It seems to not fire very often. When it does, it only fires straight ahead. I believe it is unable to rotate, or if it can, at a very small angle. The other point-defense turrets on the ship are able to rotate normally.

What's the rotation angle of point-defense turrets normally, btw?



Sorry, the ship was actually the Hurricane. (I can't seem to edit my post. When I click on "edit", it takes me to a page with nothing I can click on or use).

I just tried the Zephyr, which also has a nose turret. It also seemed to have a narrow firing angle. However, it seemed to fire more often than the Hurricane. It seemed the Hurricane would just not fire most of the time, even when a missile was flying right in front of it.


Another bug I noticed:
Sometimes I am given a mission to destroy a ship, but I can't seem to find it anywhere on the level. I have had this happen a few times, so I searched carefully at every planet to try to make sure I didn't miss it. I am pretty sure I was thorough and didn't let anything get past me. At the end of the level, it says I failed the mission.

IIRC, when the bug happens, the mission is first offered, there is no image for the targeted ship (usually it shows a picture of the ship when you are first given the mission).


Thank you for the reports, commanders! We will try to fix a lot of them for the big content update. Let us know if you have further reports.


Factory bugs

1) So, I don't know if it's a bug or a feature, but I've had it happen several times that the enemy factory has warped from its sector into the one where I'm occupying. I didn't know they could move. Are they supposed to be able to?

Anyway, also, the factory appeared in the far corner of the map. You can just see the edge of it here:
I took a screenshot of the map of the battle too, before warping out. You can clearly see it is the factory:

It had warped it from the adjacent system. Is this normal behaviour? I have had this happen a few times, because I was spending a few turns next to the enemy's factory, hoping to count how many ships it manufactured per turn.

2) Another, separate problem I observed is that sometimes a friendly battlestation will spawn in the same system as an enemy factory. This seems to only happen in relation to an "escort colony ship" mission. I've had this happen a couple of times.



I noticed that the Flak Cannon does not display the correct damage in the readout. The true value is double what is shown. (I assume this is because it has 2 guns, and only the damage for one is shown).


I have had this happen a couple times. I will have ships with a fully stocked bolter drone bay and for some reason one of them refuses to spawn and the other drones in that squad sit around instead of flying in Vs across the screen normally. The only way to get back the last fighter is to scrap and rebuild the hanger. I've had it happen at least twice.

Also, I can confirm that I have been ambushed by a factory jumping into a sector.

Users browsing this thread:
1 Guest(s)