Harbinger PC Early Access Feedback


PC, i5-4690K, GeForce GTX780, 8GB DDR3 @ 1600MHz.
Yay, had my invitation today (night). Running the update didn't seem to do anything so I ventured into the game, starting with the tutorial.
Buying the cannon was impossible, multiple clicks around and on the dot didn't select it. Had to use ESC to do it manually, and go back before the tutorial resumed.

Until the first time I bought and equipped from a space station I could not buy (manufacture, build) from the engineering room. Using both the double click or the buy button did nothing, neither would the cancel button work to get back to the engineering window. The buttons would still linger on in the engineering window afterward. First time I equipped an item solved this.

Would like to know how much an upgrade costs. So far I have not been able to see a cost associated with neither clicking on the upgrade I'd like, the button or let the mouse hover above them.

I would like to see new icon design for the improved versions, MK2, MK3 as to easier tell them apart.



Game crashed when I was defeated at a black hole sector. No error or warning. Was testing the 1920x1080 resolution. It seems to have a larger map to navigate in combat. Zooming in too close I couldn't move to the sides using the keys, zooming out I could easily put a waypoint way outside the former border.

Also, when last time the game crashed I continued when I pressed the play button. Is it possible to make a resume game button and a start game button. In case you'd like to start a new game?

I don't think I get the game, I don't get very far even on easy. Being defeated dependent on whatever I run into, usually 2 capital ships, with or without escort or hangar. Last time they warped right next to me with a close range build and made short work of me before I had a chance to get away.


Lots of crashing when entering a new system. Starting the game right back up and continuing lets me go there, just to crash 2 - 8 jumps later. Finally made it rank 2.


I found most of my crash issues went away once I turned off v-sync. Not sure if that is related or a coincidence.

Request :
- Undo command on the Upgrades screen (along with a mouse over that shows the cost


So I'd love to get some feedback but I can't get it to run. I downloaded the zip file, extracted it and ran th eexe. First I got a missing dll file error, which I fixed, and now when I go to launch the .exe, nothing happens.

Windows 7 Ultimate 64 bit
i7-4790k 4.00GHZ
16GB Ram
EVGA GeForce GTX 970

Any help would be appreciated, I'm hoping I'm just doing something stupid, but who knows.


Ok where to begin....

First and foremost I would like to start by saying that this is a very fun and addictive game, but with that said there are many issues I have ran into that I would like fixed in order to make the game playable.

My game has crashed more times then I can even count. At first I thought it may have been a conflict with maybe a action I was doing or something conflicting in the game. After many many many restarts I have came to the conclusion that it is very random when it crashes but for some reason it always does. I believe in the last mission I played the game must have crashed roughly 20-30 times.

I may be the only one or maybe I am not but I have came across a bug where I am unable to buy anything and when I back out of the buy menu the purchase button was just floating around on screen.

When doing the tutorial I would have to reload certain parts because the game thought I did not complete certain actions even though I did.

Not sure if a bug or not but sometimes the drones of the enemy ships will go off screen and become un target-able, granted the auto attacking still works but if I could direct it a little better or make it so the enemy drones dont go off screen make it a simple solution

Not sure if this will be fixed or improved but could there possibly be a way to not auto zoom into a objective? I get it collect this or destroy this....I know I must do this, that is why I went to that location to begin with.

If I choose to target a ship why is my main ship still firing and the ship I did not target? if multiple enemies are on the screen at the same time and I target lets say ship A....my ship still fires at ship B.

When I completed a map it should not say "hey you failed mission X" if i choose to move on then I am aware of what missions I am not doing, maybe before moving onto another map it could say "you are about to move onto another map, before proceeding would you like to complete the remaining missions?"

I will have to "attempt" more runs and keep track of my crashes and what not and comeback with more detailed results, also I forgot to mention when I say crash It is just that a hard crash, no errors pop up saying hey your game crashed windows is looking for a solution blah blah.

I do enjoy this game and can see it doing quite well on steam but, not until the game and the menus are flushed out more.


@dmsnarf. What did you mean with "not until the game and the menus are flushed out more" exactly? What I mean is are there other things besides the ones that you listed that you think should be added/fixed?

Thank you everyone for your feedback! Keep em' coming.


@AdmiralGeezer What I meant was, this game will do great on steam once a lot of the issues are resolved. If this game was released today with the amount of crashes that are reported, among it's other issues it would not get very good reviews I believe.

There are more Things I have been noticing that need to be fixed/improved I am still making my list. Yes some of them are minor but some are more major.

As a side update/note I also turned of V Sync and about half my crashes went away but still just after about 2 hours of play time I had about 40 crashes roughly. I will include specs and what not to show I am not playing on a complete potato.


@dmsnarf. Thanks! Yes there seems to be an issue with music/sounds from our crash reports. That is what is causing all the trouble regarding crashing. We will try to work on a fix and update. Stay tuned.



Copy-pasting from elsewhere:


I gave the early game a test run. It's quite buggy, unfortunately. Here are some suggestion as well as problems I've encountered so far:

- No one really says "tap" when playing with a PC, do they? Unless they use touch screens. I'd prefer the term "click" myself.
- Exhibit A: I began to play the tutorial, and almost immediately ran into a problem. When I was asked to build a turret, I could click (or tap) the turret. The game didn't respond to mouse clicks at all.
--- Well okay, I pressed Esc, and after that I was able to built the cannon, though the guiding finger and "Tap here" text disappeared as the piece of tutorial got sort of cancelled.
- I jumped to the next sector in tutorial. "Move around", he says, and a text box appears: Tap here. I click there. Nothing happens. The finger and text box disappear, but the ship won't react. This time the Esc trick didn't help either.
--- Gah, never mind. Seems I was supposed to first select the ship and then press the secondary mouse button... any way to make this piece of tutorial more thorough?
- The Pause button hardly changes color when pressed. A minor thing of course, since the player probably knows when the game is paused, but you know.
- Some native English speaker could polish the language a bit. For example, the second training course text could read either:
--- "We have scanned this galaxy and found multiple Schillae outposts. We believe these outposts hold many human males captive."
--- "We have scanned ... Schillae outposts, which we believe hold many human males captive."
and so on.
- Exhibit B: Umm... why are the Buy and Cancel buttons still visible on the screen? Also, I can't buy a cannon for one reason or another... and Cancel button does nothing either. I can exit the shop by only pressing Esc.
--- Restarting the game fixed this.
- For some reason I can't show this by screenshots, but when I try to buy weapons or other stuff to my ship, the ship silhouette is briefly visible behing the shopping screens, but then it disappears. When I try to take before-and-after screenshots, the ship isn't visible in before shot either...
- I continued the second mission and jumped to different sectors. One sector had an enemy ship. I destroyed it and the game froze. I couldn't Alt+Tab the screen away, so I had to Ctrl+Alt+Del to Task Manager.

Captain Kim

[Image: W5lKKoP.png]
[Image: V0MuucU.png]

Users browsing this thread:
2 Guest(s)